Thursday, February 6

IRSSI SSL errors

I was getting some really weird errors in IRSSI every time i was hilighted, but the errors seemed to be related to SSL libs, which didn't make any sense I wasn't using ssl or encryption of any type on my IRSSI (as a debugging measure, I normally do use it where possible).


Everytime someone hilighted me, I'd see something like this:

[15:12:45][+Smiley(+i)][4:Freenode/#gentoo-chat(+Ccjnt 5:10)][[242 o/2 v/32 n/20
[#gentoo-chat] *** WARNING : deprecated key derivation used.
Using -iter or -pbkdf2 would be better.
*** WARNING : deprecated key derivation used.
Using -iter or -pbkdf2 would be better.
*** WARNING : deprecated key derivation used.
[15:12]< soliwilos> Smiley: A highlight.
[15:12:47]r or -pbkdf2 would be better.
               *** WARNING : deprecated key derivation used.
Using -iter or -pbkdf2 would be better.
*** WARNING : deprecated key derivation used.
Using -iter or -pbkdf2 would be better.
*** WARNING : deprecated key derivation used.
[15:12:49]r or -pbkdf2 would be better.

Turns out it was irssinotify.pl, which I identified by doing /script, noticing it was running and then doing /script unload irssinotify which removed it. People then hilighted me again but without ill effect :)

No comments:

Search This Blog